SAP Knowledge Base Article - Public

2659632 - "Could not connect to SFTP server" when connecting to an external site - Integration Center

Symptom

An Integration Center job is calling an external new site (SFTP, SOAP, REST), but is failing with the error below:

  • "Could not connect to SFTP server {0}. Please check to see if IP Address mentioned in https://launchpad.support.sap.com/#/notes/2395508 is allowlisted by your SFTP server. Contact your IT for more information"

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP SuccessFactors HCM Suite

Cause

The allowlisting on SAP side or third-party side was not performed.

To be able to connect your SuccessFactors (SF) instance to a new external/third-party site (SFTP/REST/SOAP) is necessary to allowlist SAP DCs IPs in the third-party servers and also allowlist the third-party site IPs in SAP servers.

Resolution

For the allowlisting in third-party side, follow the KBA 2395508.

For the allowlisting in SAP side, follow the KBA 3122406.

NOTE: If both KBAs were performed and the issue persists, you need to collect at least the logs from the SFTP server which contains the connections being refused or accepted by your server and provide to SuccessFactors support team to progress on the investigation.

Keywords

Public SFTP; SFTP owned by customer; Cannot connect to SFTP; allow list by your SFTP server, ftp, connection, error, connectivity, successfactors, sf, success factors, firewall, block, blocking, 3rd party sftp, vendor sftp, third party sftp, customer sftp , KBA , LOD-SF-INT-INC , Integration Center , LOD-SF-INT , Integrations , Problem

Product

SAP SuccessFactors HCM Suite all versions