Symptom
When with the help of your Keytest user, you logon as a business user, you cannot see the Visits or other objects in their Calendar.
Environment
SAP Cloud for Customer
Reproducing the Issue
-
Go to the Administrator Workcenter.
- Go to the General Settings view.
- Click Log in as Another User.
- Click Add Row.
- Maintain the technical ID of your Keytest user as well as the one of the Business User you want to Impersonate.
- Save.
- Log onto the system with the credential of the Keytest User.
- Click the Calendar Icon.
Results: The Visits of the impersonated Business User are not showing in the Calendar.
Cause
The Keytest User has the same page layouts, data access, or query results as the Business User. If data is modified by the KeyTest user, the change is tracked with the Keytest User identity details, so that the business user data is unaffected.
However, a Business User cannot be impersonated when it comes to the Home view, Screen Personalization, Calendar, Feed, or Custom Coding.
Resolution
This is the system expected behaviour.
To find the Visits (etc.) of the impersonated user, you may look their name up via the Value Help above the Calendar.
Note: a keytest user is created from the business user as per the settings at the moment of impersonation - any changes made to the business user after this impersonation are not going to be reflected for the keytest user. A new impersonation will have to be done.
Keywords
Keytest user, Impersonated User, Calendar, Visits. , KBA , LOD-CRM-CAL , Calendar Control , SRD-CC-FED , Feeds , LOD-CRM-HOM , Home Page , How To