Symptom
While selecting the 'Coverage' field during an enrollment for Benefits, an application error occurs with fingerprint=751f0dbe2a4a782732e7c85101d772bd49deade1. Also, the error may occur when you click 'Go to Benefits' on a users profile.
Environment
-
SAP SuccessFactors Employee Central
- Global Benefits
- People Profile
- Manage Configuration UI
Reproducing the Issue
-
Navigate to an Employee's profile > Scroll down to 'Employee Benefits' portlet
- Select a Benefit > 'Enroll Now'
- Under 'Insurance Enrollment' fill out 'Plan', and 'Enrolling for' fields
- Select and option for 'Coverage' field > Application error occurs
OR
- Navigate to the profile of a user
- Scroll to the Benifits portlet
- Click 'Go to Benefits'
- Receive application error
Cause
The application error might be due to one of the below issues:
- The visibility of the field 'Enrollment Request Date' is set to 'No' or the field is blank in Manage Data -> Benefit Enrolment for. A value is expected here as this is a required field for Global Benefits.
- One of the benefit(for example: benefit tyep 'other') does not have claim start date and end date.
For Support: Please see Internal Memo attached for Splunk Logs
Resolution
Issue 1:
This issue is resolved by setting the Visibility of the field to 'Yes'. To do so;
-
Navigate to Admin Centre > Tool Search >'Manage Data'
- In the left search box, search for 'Benefits Screen Lookup' > In the right searxch box, search for 'BenefitEnrollment'
- Copy the 'Screen ID' (it is usually 'BenefitEnrollmentConfigUI')
- Search for 'Manage Configuration UI' > Enter the Screen ID
- Hover your mouse over the 'Enrollment Request Date' field > Click 'Edit Properties' > Set 'Visible' to 'Yes'
- Save
To set value to this field for a benefit enrollment:
- Navigate to 'Import and Export Data'
- Select Export and choose 'Benefit Enrolment'
- Change the value of 'Select all data records' to 'No' and enter the Benefit Enrolment
- Extract the files and open the file Benefit Enrolment.csv. Add a date to the column 'enrollmentDate' for each record (This should be the same value as the column effectiveStartDate).
Note: There are a lot of csv files that may not be needed. These can be removed to to make the process quicker. If these files are removed, the file 'import_sequence.csv' will also need to be updated.
- Once you are finished zip the relevant files (select them all and right click and choose Add to Archive)
- Navigate to Manage Data and select 'Import Data' and then select 'Zip File'.
- Select your zip file and then click Import.
- You can now navigate to Monitor Job to check the progress of the import
This fingerprint error code is shown also when we try to save emergency contact information.
Verify that the "Manage Business Configuration" admin tool > homeAddress portlet, the field 'disabled for dependents' is set to 'yes'. Since this field is set to yes the home address will not be fetched for dependents. So please set the flag to no and try saving emergency contact. This should solve the issue.
Issue 2:
Add claim start date and end date to the beneft schdule period which do not have claim start date and end date.
Keywords
fingerprint=751f0dbe2a4a782732e7c85101d772bd49deade1, 751f0dbe2a4a782732e7c85101d772bd49deade1, Global Benefits, Application Error, Insurance Enrollment, Enrollment Request Date, Coverage, emergency contact save error, enrollment , KBA , LOD-SF-EC-GBF , Global Benefits , Problem