SAP Knowledge Base Article - Public

2660794 - Account Manager Can't See the Sales Orders Maintained on the Account

Symptom

The user ABC (ABC represents the User ID) has restrict access to Sales Orders based in the Restriction Rule 11 (Employee, Accounts (Account Team)) and this user is part of the Account Team of the account XYZ (XYZ Represents the Account ID), but he cannot see the sales orders maintained on the Sales Order facet under the Account screen.

Environment

 SAP Hybris Cloud for Customer

Reproducing the Issue

  1. Log in the system with user ABC credentials.
  2. Go to the Customers work center.
  3. Open the Account XYZ.
  4. Go to the Sales Orders facet.
  5. You can't see the sales orders maintained on this account.

Cause

If these sales orders are maintained on the account DEF (DEF represents the Account ID), which is a Ship-to Party maintained on Relationships facet of the account XYZ, the user will not be allowed to see these sales order.

The Restriction Rule 11 will allow the user to see only the sales orders that have the account of the user ABC maintained on the Account field.

Resolution

This is the expected system behavior.

You need to maintain the user ABC on the Account Team of the account DEF in order to allow the user to see these sales orders.

Once the user ABC is part of the Account Team of the account DEF, he will be able to see these sales orders on the Sales Order facet under the Account XYZ screen.

Keywords

Sales Order, Account Team, Restriction Rule 11, Ship-to Party , KBA , LOD-CRM-ACC , Account , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions