Symptom
An email output is set up. However, it fails with message "Error: Sender domain in 123@xxx.com isn't allowed".
or
Error DT_EMAIL_SETTINGS (Expression): Domain in sender email address 123@xxx.com occurs when defining Sender Email in Output Parameter Determination.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
Take purchase order as an example:
-
Create a purchase order with an email output.
-
The email output isn't sent out, it fails with message "Error: Sender domain in 123@xxx.com isn't allowed".
or
- Open app Output Parameter Determination
- Set up business rules for the email settings for purchase order
- Define sender email 123@xxx.com and system returns the error "DT_EMAIL_SETTINGS (Expression): Domain in sender email address 123@xxx.com is not allowed"
Cause
The domain of the sender email address is not maintained correctly.
Resolution
-
Open the configuration activity "Define Allowed Email Sender Domains For Email Outbound" (ID: 101313).
-
Input the correct domain name of the sender email address in the configuration.
Examples:
- company.com would allow all email addresses in this domain such as John.Doe@company.com
- *.company.com would allow all email addresses in company.com subdomains such as John@sales.company.com or Doe@service.company.com
In case email address in the error message is 'do.not.reply@sap.com': Since SAP S/4HANA Cloud Public Edition 2108, checks were introduced to prevent the usage of SAP domains (@sap.com or sap.com) in the configuration activity "Define Allowed Email Sender Domains For Email Outbound" (ID: 101313).
See Also
See set-up instructions in 1LQ.
Keywords
sender domain, domain, OM: Sender Domains, output, SSCUI, output management, 101313, Default Sender Address, Purchase Order, Goods Receipt, Under Delivery, DT_EMAIL_SETTINGS , KBA , CA-GTF-OC , SAP S/4HANA output management , Problem
SAP Knowledge Base Article - Public