Symptom
- The drop-down for a picklist field on an application is displaying values that are currently not present in the picklist associated to that field.
- How is it possible for a value to appear in the drop-down list if it is not currently present in the picklist?
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- There is a field in the Application Template which is of data-type picklist
- Find the corresponding picklist for this field (Use KBA2463527 for more information on how to do this)
- Find the field in the application, and compare the values in the drop-down to the values in the corresponding picklist
- Notice a value is shown in the drop-down not present in the picklist
Cause
- The picklist being used for this field has been changed.
- In the past, a different picklist was used for this field, and now some of the values from the old picklist are being shown.
- This will only occur to candidates who created their application before the picklist was changed, thus the issue will not persist for new candidates.
- This can also occur for new applications when the candidate has previously created an application for another job requisition where the old picklist was being used, and forward-intact is equal to "true" in the application template.
- This is because the value of the old picklist is forwarded to the new application, despite the picklist being changed.
Resolution
- For applications being affected by the forward-intact="true" attribute in the Application Template, change the value from "true" to "false". This will resolve the issue.
- To implement this change, contact your implementation partner, or make the change through the Manage Templates feature (please see KBA 2365214).
See Also
Keywords
picklist, values, changed, drop-down, different, application, inconsistent, field, wrong , KBA , LOD-SF-RCM-APP , Applicants and Job Applications , Problem
Product
SAP SuccessFactors Recruiting all versions