Symptom
You have defined a workflow, where recipient determination is maintained for customer and you see it sends e-mail to all the address maintained.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
-
Go to Administrator Workcenter
- Go to Workflow Rules view
- Open the workflow rule XYZ1 (Where XYZ1 is workflow of type E-Mail )
- In the overview , you see that the recipient determination is maintained as customer.
Once the workflow is triggered, you see that all the E-Mail address maintained for the business partner are receiveing an Email.
Cause
While triggering E-Mail for workflow , system reads all the addresses for the associated business partner from the address overview , irrespective of the main indicator.
Resolution
This is the expected system behavior.
Keywords
E-Mails, Workflow, Business Partners, Address, Customer , KBA , contact , account , employee , email , partner , individual customer , LOD-CRM-WKF , Workflow , LOD-CRM-ACC , Account , LOD-CRM-CON , Contact , LOD-CRM-LM , Lead Management , Problem