SAP Knowledge Base Article - Public

2661142 - How to map Exisiting Contacts to Multiple Accounts

Symptom

You want to map exisiting Contacts in the system to more than one Account.

or

When you migrate exisitng Contact in the system mapped with multiple Accounts, duplicate Contacts are created.

Reproducing the Issue

  1. Go to Business Configuration workcenter.
  2. Select Overview.
  3. Search Migration of Customers.
  4. Your Migration Template has exisiting Contact mapped to a new Account.
  5. Upload your Migration Template and change the migration mode to Enhance already exisiting records.
  6. Once the migration is finished, you observe there are duplicate Contacts created in the system.

Expectation: Exisiting Contact should be mapped to another Account.

Cause

Using Migration with Enhance Already Existing Records mode will create new entries for the Contacts in the system.

Resolution

For your requirement use Data Workbench. Follow below steps for the solution:

Add Contacts in the system:

  1. Go to Data Workbench workcenter.
  2. Select Import view.
  3. Select Individual Object option.
  4. Select Insert.
  5. Search object Contacts and download metadata for Contacts.
  6. Upload the file to Import Contacts without linking to Accounts.

For linking Contact to the Accounts, follow below steps:

  1. Go to Data Workbench workcenter.
  2. Select Import view.
  3. Select Individual Object option.
  4. Select Insert.
  5. Search object Account Contact Relationship.
  6. Download the metadata.
  7. Upload the file to map exisiting Contact with multiple Accounts.

Keywords

Map Existing Contacts, Account , KBA , map existing contacts, account , map contacts to multiple accounts , LOD-CRM-INT-DWB , Data Workbench , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions