Symptom
You want to delete a scoped element within your Business Configuration after the system has gone live but the delete option is not available.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
This issue can occur in several different areas of the Business Configuration after your system goes productive, below is an example:
-
Go to the Business Configuration work centre.
- Go to the Implementation Projects view.
- Open the Activity List.
- Find and select the activity Activities.
- Select the entry 0001 Customer Visits.
Result: The delete option is greyed out. You get the following error message:
'Unassigning category 123 (123 represents the category) not possible; category in use'.
'Save failed'.
Cause
The screen showing the disabled delete buttons protected. Protected means that after you went Live with the system, entries can no longer be deleted (but added). While this is not the case for all decisions made within the Business Configuration, it is true for several selections that can no longer be undone after the system goes productive. You may find that certain changes are allowed within your test system despite not having them available within the productive environment. While not all selections made before go-live are irreversible, there are certain selections that you will no longer be able to change, once they were in use.
Resolution
This is expected system behaviour.
See Also
1950762 - Cannot Delete Appointment Category Customer Visit
Keywords
delete, Business Configuration, greyed out, grayed out, Activities, Summaries, Implementation Project, Customer Visit, delete button, Unassigning category 0001 not possible; category in use
'Save failed'. , KBA , LOD-CRM-ACT-VST , Visit Planning , Problem