SAP Knowledge Base Article - Public

2661973 - Picklist Error on Internal Candidate Profile - Recruiting Management

Symptom

When you are updating the background information in an internal candidate profile, on the side of a picklist field you can see a Red message written on the side: Picklist Error.

Environment

SAP SuccessFactors Recruiting Management

  • Candidate Profile;
  • sm-mapping;

Reproducing the Issue

  1. Access an Internal Candidate Profile;
  2. in the Backgroun Information portlet, add a new record, and on the side of the picklist field you can see "Picklist Error";

Cause

This is caused by a inconsistency of the configuration between the Candidate Profile Template and the Data Model (Employee Profile).

Resolution

To resolve this, download the Candidate Profile Template and the Data Model.

  1. Open the candidate Profile Template and access the Background-Element where the picklist error is appearing;
  2. Find the field inside it, and take note of the id and the field-name;
  3. Open the Data Model, and search for the same Background-Element;
  4. Try to find the field inside it, it should not be present or have a different field-name;
  5. Add the new missing field;

All the fields inside the Candidate Profile Template Background-Element that is being used in a sm-mappping need a destination field in the Data Model, so make sure you have all the fields with the correct field-name on both templates.

Keywords

Picklist Error, Background, background-element, data model, candidate profile, template, Internal , KBA , LOD-SF-RCM-CAN , General Candidate Issues (not Offers, not Profiles) , Problem

Product

SAP SuccessFactors Recruiting all versions