SAP Knowledge Base Article - Public

2662423 - Multiple Direct Deposit Accounts are allowed by the system with the same Customized Pay Type

Symptom

In the Payment Information/Direct Deposit portlet the system allows to Input two entries of direct deposit information of the same type. Can this be validated to prevent users from inserting multiple Entires for the Same Custom Pay Type?

Environment

  •  SAP SuccessFactors HCM Core - All Versions
  •  Employee Central - All Versions

Reproducing the Issue

  1. You have configured Custom Pay Types (E.g: Primary, Secondary, etc.)
  2. The system allows users to Input Two Pay Types of the same kind
  3. This results in a user having multiple Payment Information entries of the same Custom Pay Type (Two Primary or Two secondary Direct Deposit Accounts)

Cause

This is an Expected Behavior

Resolution

  • The validation is only available as a hard-coded feature for Standard/Pre-Delivered Pay Types
  • This validation cannot be applied on Customized Pay Types (By using Business rules etc.)
  • However, there is a duplicity check for Customzied Pay Types : 

Eg: If you enter the same Pay Type twice with the same Bank Account details - it will throw an error when saving to tell you there is a duplicate, but the system will allow you to enter duplicate Pay Types where the Bank Account is different. (Except for "Main Payment" type which only allows just 1 entry)

Keywords

SF, EC, Success factors, Duplicate Pay Type , KBA , LOD-SF-EC-PAY , Payment Information (Bank Information) , LOD-SF-EC-RUL , DO NOT USE - Business Rules & Event Derivation , How To

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Core all versions