Symptom
You want to know how is the owner field determine while creating a new contact.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
-
Go to the Customers work center
- Go to the Contacts view
- Select New button
- Enter the account
The owner assignment automatically does not happen.
Cause
There is no automatic owner determination rule when creating new contact. Also the login user is not added as contact owner.
Resolution
This is an expected system behavior.
In case if you want to determine logged in user as owner while creating a new contact, follow the below mentioned workaround:
-
Go to the Administrator work center
- Go to the Workflow rules view
- Select New
- Select the Business Object: Contact
- Timing: On Create only/ On Every Save (based on business requirement)
- Go to 3rd step Define Action
- From the dropdown select Rule Type: Action
- From the dropdown select Action: Assign Me as Owner
- Click on Next
- Click on Activate button in 4th Step Review
- Finish
After following above steps if you create new contact, logged in user assign automatically as owner after saving contact.
Keywords
Contact owner determination , KBA , owner , determination , new contact , LOD-CRM-CON , Contact , LOD-CRM-ACC , Account , How To