SAP Knowledge Base Article - Public

2662811 - Determination of Owner While Creating a New Contact

Symptom

You want to know how is the owner field determine while creating a new contact.

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

  1. Go to the Customers work center
  2. Go to the Contacts view
  3. Select New button
  4. Enter the account

The owner assignment automatically does not happen.

Cause

There is no automatic owner determination rule when creating new contact. Also the login user is not added as contact owner.

Resolution

This is an expected system behavior.

In case if you want to determine logged in user as owner while creating a new contact, follow the below mentioned workaround:

  1. Go to the Administrator work center
  2. Go to the Workflow rules view
  3. Select New
  4. Select the Business Object: Contact
  5. Timing: On Create only/ On Every Save (based on business requirement)
  6. Go to 3rd step Define Action
  7. From the dropdown select Rule Type: Action
  8. From the dropdown select Action: Assign Me as Owner
  9. Click on Next
  10. Click on Activate button in 4th Step Review
  11. Finish

After following above steps if you create new contact, logged in user assign automatically as owner after saving contact.

Keywords

Contact owner determination , KBA , owner , determination , new contact , LOD-CRM-CON , Contact , LOD-CRM-ACC , Account , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions