Symptom
When simulating/receiving Inbound Phone Call from Individual Customer in RUI Fiori, system does not recognize the caller. However, the system does recognize the caller in HTML5.
Environment
SAP Cloud for Customer
Reproducing the Issue
Prerequisite: You have already maintained settings to enable Inbound Phone Calls in your system and created Individual Customer with phone number maintained.
- Log in using RUI Fiori.
- Go to the Service work centre.
- Go to the Live Activity Centre view.
- Open CTI Client Adapter.
- Simulate Inbound Phone Call from Individual Customer ABC (ABC represents the name of the Individual Customer).
- Notice that caller has not been recognized.
Cause
You do not have Individual Customers maintained as a searchable object in the Live Activity Configuration.
Resolution
This is the expected system behavior. To have the Individual Customers recognized in RUI Fiori client, follow the steps below:
- Go to the Administrator work centre.
- Go to Service and Social view.
- Select Live Activity Configuration.
- Click Add under Search Objects.
- Select Individuals from the dropdown list.
- Click Add.
- Click Save and Close.
Keywords
CTI, Individual Customer, Live Activity, RUI Fiori, Inbound Phone Call , KBA , LOD-CRM-LA , Live Activity , Problem