SAP Knowledge Base Article - Public

2663432 - Status Requires Work Not Visible In Ticket Due To Error Message 'Please enter a party with role Planner'

Symptom

You receive error message 'Please enter a party with role Planner' and status Requires Work is not available for selection in Tickets.

Environment

SAP Cloud For Customer

Reproducing the Issue

Prerequisites: You have marked party Role Planner as mandatory in Business Configuration. You have created a Ticket where Planner is not maintained.

  1. Go to the Service work center.
  2. Go to the Tickets view.
  3. Open the Ticket XYZ (XYZ represents the Ticket ID).
  4. Click Edit.
  5. Open dropdown list for field Status.
  6. Notice that status Requires Work is not available for selection and you can see error message: 'Please enter a party with role Planner'.

Cause

The Ticket XYZ is inconsistent, due to the following error message 'Please enter a party with role Planner'. There is no Planner maintained in the Ticket. The status 'Requires Work' is not displayed due to the error message.

Resolution

This is expected system behavior.

Planner Action status is not displayed if:

  • Ticket is inconsistent.
  • Ticket is Completed.

To solve the issue, enter a party with role Planner in the Ticket and status Requires Work will become selectable.

See Also

Blog: How to maintain Document Type and Status Schema in Fine-Tune and it’s determination in Ticket

Keywords

Ticket, Requires Work, Planner , KBA , LOD-CRM-SRP , Service Request Processing , Problem

Product

SAP Hybris Cloud for Customer add-ins 1711