SAP Knowledge Base Article - Public

2663653 - Unable to Open E-mail Attachments in Ticket Interactions

Symptom

When you try to open an attachment of “.rfc822" type in an email, the error message occurs as “It’s possible the file is already open, or you don’t have permission to open it”.

Another common scenario is that you see "noname" attachment files which you cannot open due to security error messages.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Service work center.
  2. Go to the Tickets view.
  3. Open ticket ABC (ABC represents the ticket ID).
  4. Navigate to the Interactions tab.
  5. Open an attachment with the format MSG.
  6. Format of the attachment changed to RFC822.

Cause

Issue is due to incorrect configuration of MIME type in the system. You have not selected the File Extension EML as default under Mime Type: message/rfc822.

Resolution

  1. Go to the Business Configuration work center.
  2. Go to the Overview view.
  3. In the dropdown menu, select: All configuration elements.
  4. Search for and open Allowed MIME Types for Document Upload activity.
  5. Click Change Immediately button.
  6. Search for Mime Type: message/rfc822.
  7. Select the record and in the File Extension section, uncheck the default flag against MSG.
  8. Change the following entry: EML default = 'X'.
  9. Save and close.

Note: The configuration does not work for old e-mails as the attachments in them are already processed.

Keywords

ticket, attachment, interactions, mime, mime type, msg, eml, rfc822, message/rfc822, file, e-mail, contains macros, security guidelines, noname.msg, noname.eml , KBA , msg , rfc 822 , noname.msg , LOD-CRM-SC-EML , Email , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions