SAP Knowledge Base Article - Public

2664337 - Credit Limit Displays Incorrect Values for Contracts

Symptom

The Credit Limit check displays incorrect values for Customer Contracts.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Navigate to the Sales Order workcenter.
  2. Create a new Sales Order.
  3. Enter customer ABC (ABC represents the customer ID).

The Credit Limit Check shows 1000€.

  1. Navigate to the Contract view.
  2. Open Contract DEF (DEF represents contract ID) from customer ABC.
  3. Check the Credit Limit.

The Credit Limit check shows 500€.

Cause

  • The Credit Limit check does not consider open Invoice Amounts from Customer Contracts unless it is performed within the contract with open Invoice Amount.
  • When creating a new sales document, the Credit Limit check considers all to-be-invoiced items from Sales Orders and Service Orders.
  • Customer Contract Line Items are generally not considered in the Credit Limit check.
  • Only when performing the Credit Limit check from within a contract with open Invoice Amount, this Amount is be considered.

Please note: that the Invoiced Open Amount is determined from the receivables of the account and only the Posted Items are taken into consideration. The Statistical Items are not taken into consideration for the Invoiced Open Amount.

Resolution

This is the expected System behavior.

  • For contract DEF there is an open amount of 500€.
  • When performing a credit check on a new document this open Invoice Amount will not be considered.
  • When performing the Credit Limit check in contract DEF, all sales orders will be considered (depending on scoping) and additionally the open Invoice Amount from contract DEF.

Keywords

Vertrag, Kundenauftrag, Kreditlimit, Kreditlimitprüfung, Customer Contract, Sales Order, Credit Limit Check, , KBA , AP-SLO-SO , Sales Order , AP-CCP-CC , Customer Contract , Problem

Product

SAP Business ByDesign 1805 ; SAP Business ByDesign 1808 ; SAP Business ByDesign 1811