Symptom
This article describes one of the root causes for an Application Error on Deleting Candidate Document.
Environment
SuccessFactors Recruiting Management (RCM)
Reproducing the Issue
1. Go to Recruiting.
2. Go to Candidates.
3. Open a Candidate Profile.
4. Delete any attachment and click on OK.
5. The Error ID may differ but you will get a fingerprint which is as follows: fingerprint=a2a85bf7e8ec2a099f37fa190ad1cc96278019d1.
Cause
The attachments were saved through OData API with ModuleCategory = "Attachments," which is not the expected ModuleCategory.
Resolution
The fix for this issue requires that module category be ignored on deletion. This feature is being considered for enhancement. If you encounter this issue, please file an enhancement request on the SuccessFactors Community to add weight to this request.
See Also
Keywords
Attachments; Candidate; fingerprint=a2a85bf7e8ec2a099f37fa190ad1cc96278019d1; , KBA , LOD-SF-RCM-APP , Applicants and Job Applications , Problem