SAP Knowledge Base Article - Public

2665232 - You Are not Able to Mark the Checkbox Expense for a Service Item After Saving

Symptom

  • You create a document with services Expense - Fixed price without actuals
  • When you add the service in a new sales order you get the error message

'Service product and item type code do not match.'
'Check your service master data to ensure that you have not defined a service product with an item category group for expenses, or vice versa.'

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go To the Sales Order Workcenter.
  2. Go To the New Sales Order View.
  3. Fill out the mandatory data.
  4. Go to the items tab and choose a service expense -Fixed price without actuals.

Now you see the error message:
'Service product and item type code do not match. Check your service master data to ensure that you have not defined a service product with an item category group for expenses, or vice versa'

  1. Go to the Product and Service Portfolio work center.
  2. Select the Services view.
  3. Select All Services in the Show field.
  4. Select and Edit service ID: Service: ABC (represents the service ID)
  5. Go to the Sales Tab.
  6. In Item Group field you can see the actual value to Fixed price without actuals
  7. Go to General Tab.

Here you can see that the expense field is not marked as expense in the service master data.

Cause

The error message occurs because the item type of the service is XFIX - Expense - fixed price without actuals, but the Expense flag is not ticked in the service master data. Once a service is saved it is not possible to mark a service product as an expense service any more.

Resolution

You have to create a new service with the marked expense field.

Keywords

Service, Service product, Item Code, Fixed price, Festpreis, Checkbox , KBA , service , checkbox , item code , festpreis , fixed price , service product , SRD-MD-PRD-SRV , Service , How To

Product

SAP Business ByDesign all versions