SAP Knowledge Base Article - Public

2665246 - Super administrators are unable to edit the PUBLIC domain

Symptom

Super administrators (ex. admins assigned the ALL role) can view the PUBLIC domain but cannot edit it - see screenshot below:

CS-PUBLIC_Domain_ViewOnly.png

Environment

SAP SuccessFactors Learning Management System (LMS)

Reproducing the Issue

  1. Go to System Admin
  2. Click Security
  3. Verify that you are on Domains
  4. Search for domain ID "PUBLIC"
  5. Notice that the edit button is missing

Cause

x-tinymce/html

The default domain is set as Public in Search selectors.

Resolution

  1. Go to System Admin
  2. Configuration tab
  3. Search Selectors
  4. Find and edit the "Domain" search selector
  5. Search for "selectClause.mainSqlClause", where you will observe the following: selectClause.mainSqlClause=dmn_ID, dmn_DESC,STYLE_ID, 'PUBLIC' as default_domain
  6. Replace the PUBLIC domain with another domain from your LMS, and click Apply Changes

Keywords

PUBLIC domain uneditable edit modify cannot can't search selector unable admin administrator , KBA , LOD-SF-LMS-WOR , Roles & Workflows , Problem

Product

SAP SuccessFactors Learning all versions

Attachments

CS-PUBLIC_Domain_ViewOnly.png