SAP Knowledge Base Article - Public

2665333 - Submit for Approval Button Grey Out in Sales Order

Symptom

You are not able to submit a sales order for approval, since the “Submit for Approval” option is greyed out.

Environment

SAP Cloud for Customer

Reproducing the Issue

The same behaviour can happen for Sales Quotes.

  1. Go to the Sales work center.
  2. Go to the Sales Orders view.
  3. Open sales order XYZ and navigate to Action button (XYZ represents the order ID).

Result: You find that the option “Submit for Approval” is greyed out.

Cause

There are several reasons for the Approval button to be disabled. Here are the main ones:

(1) The sales order does not meet the conditions maintained for sales order approval as per the Approval Process definition (Administration work center > Approval processes view > Sales Orders approvals).

(2) The sales order has a product maintained but the product does not have pricing. This would lead to an error of price calculation in the backend and disable the Approval Button.

(3) The Sales Order was previously submitted for approval but had its transfer revoked. Please, refer to KBA: 2613644 - Sales Order Submit For Approval Button Grayed Out After Transfer Revoked .

(4) There is a custom rule which greyes out the "Submit for Approval" field. You can check if this is the case, by clicking Adapt > Disable Key User Properties. If the field become available now, you need to check your custom rules.

(5) There is a PDI affecting the standard approval process.

Resolution

(1) You need to maintain approval process conditions that match your Sales Order.

  1. Go to the Administration work center.
  2. Go to the Approval Processes view.
  3. Click on Sales Order Approvals.
  4. Maintain some conditions that match your sales order.

(2) If you have a sales order without pricing, you need to maintain product price for internal order to process further on sales order.

After you maintained the product price, create a new sales order and add the product. You may find the price still shows empty and no method to enter a price with the field also greyed out in Edit mode.

In that case you need to check the following steps:

  1. Please check if Multi-step approval is enabled in the Business configuration questions for Sales Order which will enable the Submit for Approval action.
  2. Check if there is an active approval process defined for Sales Order under Administrator->Approval Processes. Check the process steps and condition defined there.
  3. Check you Business Configuration -> Open the Fine Tuning Activity List -> Search for “Sales Orders” and open “Maintain Document Types”. For order document types with maintenance mode as “Internal and External”, the Price will come from ERP and not from the price list.

See Also

FAQ about Sales Orders

KBA: 2613644 - Sales Order Submit For Approval Button Grayed Out After Transfer Revoked

Keywords

Sales Order; Sales quote ; Submit for Approval; grey out; approval process ; pricing ;  transfer revoked ; custom rule ; ERP , KBA , LOD-LE-CQP-CO , Lean Sales Orders , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions