Symptom
The error message Item not included in product list is triggered when adding a product to a Sales Order.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
-
Go to the Sales work center.
- Go to the Sales Order view.
- Open any Sales Order ID.
- Go to the Products tab.
- Select the Add button.
- In the Product OVS, choose the Product DEF (DEF represents the Product ID).
- Error message Item not included in product list is triggered.
Cause
The Product DEF is not part of a Product List.
In the Business Configuration work center, you have selected the scoping question Do you want to allow adding products only from Product List? Because of this, you can only add Products that are part of a Product List.
Resolution
You can either add the Product DEF to a Product list of un-scope the question in the Business Configuration work center:
-
Go to the Business Configuration work center.
- Go to the Implementation Projects view.
- Select Edit Project Scope.
- Go to the Questions tab.
- Expand the element Sales --->New Business --->Sales Orders.
- Uncheck the question Do you want to allow adding products only from Product List?
- Select Next --->Finish.
You can now add Products that are not part of a Product List.
Keywords
KBA , sales , item not included in product list , sales order , LOD-LE-CQP , Customer Quote Processing , Problem