Symptom
You upload a Service Category Catalog in a language that contains special characters (eg. Arabic, Chinese etc.), but the values are just shown as a number of question marks in the system.
Environment
SAP Cloud for Customer
Reproducing the Issue
Example: Arabic values in the Service Catalog
- Create a file that includes the necessary information for the service catalog and the Arabic values like Name, Description, etc.
- Save the file in the .csv format.
- Go to the Administrator work center.
- Select the Service and Social view.
- Select the Service Categories hyperlink.
- Select the New button and choose the option Catalog from file.
- Select the .csv file.
- Select the Upload button.
- Log in to the system in Arabic.
- Go to the Administrator work center.
- Select the Service and Social view.
- Select the Service Categories hyperlink.
- Open the created Service Category Catalog ABC (ABC represents the Catalog ID).
The values in the Catalog are shown as multiple question marks(???) instead of the Arabic values.
Cause
Microsoft Excel does not support certain special characters (eg. Arabic, Chinese etc.) in the .csv format.
This can be seen after saving the file in the .csv format, closing the file and re-opening it. The values are already displayed as question marks.
This means that the file can be uploaded without an error, but in the UI the characters will be shown as multiple question marks, as it is in the .csv file.
Resolution
- You can create a Service Category Catalog manually, or upload the Catalog in a language that is supported by excel in the .csv format and maintain the values in Arabic manually.
- Another workaround is, while conveting excel into .csv save it in utf-8. Then the value can be displayed in the .csv format.
Keywords
Service Category; Catalog Upload; Arabic; Chinese; Japanese; Russian; Question Mark; ??; Not Displayed Correctly; , KBA , LOD-CRM-SRP , Service Request Processing , How To