Symptom
Error on creation of Report through report Canvas Using Report Center.
Environment
SAP SuccessFactors HXM Suite
Reproducing the Issue
- Navigate to Reporting > Report center > New
- You have the Canvas report option available
- Select to create a ORD/ODS Report
Result:
"Please click this link to automatically search for any Knowledge Base Articles related to this error, or refresh the page and try the action again."
"errorId=0304dfc4-4c8c-4af1-8f68-010165c58c7d, fingerprint=4b79a1bd6e7c1c301bd2a1eadcef2f07198ba62a, timestamp=xxxx-xx-xxTxx:xx:xx.xxx+xxxx, errorMessage=An application error occurred. Please try again later, or notify support (with the error information of errorId=0304dfc4-4c8c-4af1-8f68-010165c58c7d, timestamp=xxxx-xx-xxTxx:xx:xx.xxx+xxxx, and the version information from the current screen) if the issue keeps occurring.,"
Cause
The reason for the mentioned error is missing ORD configuration from Provisioning.
Resolution
- Login to Provisioning (In case Customer doesn't have access, you can raise an Support case)
- Check for ORD Configurations
- Points to Notice:
- Check on provided urls, there shoudn't be any white spaces and Special character like double colon "::" in assertion urls.
- Check for all the relevant checkboxes as mentioned below, there must be any of these unchecked leading to this issue
- Single Sign On
- Enable SAML for SSO
- Online Report Designe
- Provide and Save it.
- Log back in to Instance and cross verify the issue should be resolved.
Keywords
Canvas report, FingerPrint Error,ORD configuration,ORD/ODS Report, Report Center Error , KBA , LOD-SF-ANA-RCT , Report Centre , LOD-SF-ANA-ADV , Advanced Reporting (ODS) , Problem