Symptom
When trying to import work orders for contingent workers, an error occurs stating that system cannot find the vendor codes that are referenced in the import file, even if the vendors are created with the code that is referenced and are active and valid at the time of import.
Environment
SuccessFactors Employee Central: Contingent Workforce Management
Reproducing the Issue
- Go to Import and Export Data
- Download the template for Work Order
- Fill the values and import the work order file
- Go to Monitor Jobs and Download Status of the failed import
Cause
The field 'effectiveStartDate' is not visible in Work Order object definition, hence does not come up in the import file. This field is needed when importing work order
Resolution
Either make the field editable in Work Order object definition, so that it comes up in the import template or add the field manually in the template.
Keywords
Work Order, Import, error, vendor code, employee central, contingent worker , KBA , LOD-SF-EC-CWF , Contingent Workforce , Problem