Symptom
- A B2C email channel has been configured to create new individual customers when the sender's email address is unknown.
- A custom role has been defined as the default role for newly created customers under the Maintain Customer Roles option in the Accounts activity of Business Configuration.
- However, the system defaults to the standard role Customer instead of applying the custom role.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Business Configuration → Open Activity List
- Go to the Accounts fine-tune activity
- Click on the option Maintain Customer Roles
- Click on Add Row and add a new custom role
- Tick the checkbox for Default Role for this newly created custom role
- Click on Save
- Send an e-mail to the B2C channel from an e-mail address not assigned to any Contact
- New individual customer will be created with the standard role Customer and not with the custom role.
Cause
- The system does not currently support setting a custom role for customers created via the email channel.
- All emails received in this scenario default to the standard role Customer.
Resolution
- This is the standard behavior of the system.
- If the feature/functionality is needed as a matter of urgency, please refer to KBA 3475641 - Functionality Currently not Available.
Keywords
B2C email channel, custom role, default role, SAP Cloud for Customer, customer creation, email channel issue, maintain customer roles, standard role, individual customer, SAP Cloud Service Center, customer influence site, email sender unknown, business configuration, accounts activity, default role checkbox, SAP application development. , KBA , LOD-CRM-SC-EML , Email , LOD-CRM-SRP , Service Request Processing , LOD-CRM-ACC , Account , LOD-LE-BP-BP , Business Partner , Product Enhancement
Product
SAP Cloud for Customer core applications all versions
SAP Knowledge Base Article - Public