Symptom
You try to maintian a European payment bank for a non-European employee, however, system does allow to add IBAN code from UI which is required for payment.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Personnel Administration work center.
- Go to Employees view.
- Search for Employee ID XYZ(XYZ represents employee ID).
- Select the row and click on Edit.
- Move to Personal Data tab and navigate to Payment Information sub tab.
- Click on Add Row under section of Bank Accounts.
- Maintain a European bank.
Error 'IBAN required for country ABC(ABC stands for the country of bank) to support SEPA payments' prompts. You notice that the IBAN field is not visible as well. The field is not available for selection even using Personalize or Adapt modes.
Cause
As per current functionality, IBAN field is visible in the personnel file of the employee whose country of employment is a European country. However, adding IBAN field in the personnel file of employee belonging to a non-European country would be a new requirement.
Resolution
Currently the workaround to add an account with an IBAN for a non-European employee is to login as a active employee using employee credentials and maintain bank details with following steps:
- Go to Home work center.
- Go to Self Services view.
- Open Edit Reimbursement Settings.
- In the first step, choose Select Use Separate Settings for Expense Reimbursement, click on Next.
- Select payment method as Bank Transfer and then click on New Bank Account, maintain Bank Details (IBAN field is available on this screen) and save the changes.
The same bank account will now be available in the personnel file as well.
Keywords
IBAN missing, European country, payment bank , KBA , SRD-HR-PAD-US , USA , Problem