SAP Knowledge Base Article - Public

2666423 - You Are Not Able to Change an Account Once the Visit Is Created

Symptom

You are trying to change an Account inside a Visit but the field is grayed out.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Visit work center.
  2. Click on Visit.
  3. Click on New.
  4. Select the Account ABC (ABC represents the ID of the Account).
  5. Complete the mandatory fields.
  6. Save and Open.
  7. Click on Edit.
  8. Result: Account field is grayed out.

Cause

The visit contains any existing tasks or Surveys.

Resolution

This is the current system behavior. If the associated surveys or tasks are removed, the account can be changed again.

Keywords

Visit ; Field; Accounts , KBA , LOD-CRM-ACT-VST , Visit Planning , LOD-CRM-ACT , Activities , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions