Symptom
You are trying to change an Account inside a Visit but the field is grayed out.
Environment
SAP Cloud for Customer
Reproducing the Issue
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Go to the Visit work center.
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Click on Visit.
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Click on New.
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Select the Account ABC (ABC represents the ID of the Account).
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Complete the mandatory fields.
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Save and Open.
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Click on Edit.
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Result: Account field is grayed out.
Cause
The visit contains any existing tasks or Surveys.
Resolution
This is the current system behavior. If the associated surveys or tasks are removed, the account can be changed again.
Keywords
Visit ; Field; Accounts , KBA , LOD-CRM-ACT-VST , Visit Planning , LOD-CRM-ACT , Activities , How To
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions
SAP Knowledge Base Article - Public