SAP Knowledge Base Article - Public

2667346 - Order Confirmation Email is failing

Symptom

Error message - 'Recipient address ...<email id of sold to>... not allowed' is encountered.

Environment

  •  Sales and Distribution (SD)
  •  SAP S/4HANA Cloud All versions 

Reproducing the Issue

  1. Open the Launchpad with role: SAP_BR_INTERNAL_SALES_REP.
  2. Access app 'Change Sales Order' and open a Sales Order.
  3. Trigger an output from ORDER_CONFIRMATION for email channel.
  4. Output is triggering but it is not reaching to destination email id.
  5. The Display log shows message: 'Recipient address ...<email id of sold to>... not allowed'.

Cause

This is caused by a mis-configuration of the feature. Email Receiver Addresses require specific configuration with a Test system, where an allowlist of receivers has to be maintained.

Resolution

Refer to the Configure Guide: 4.1.3 Email Receiver Addresses for Test Systems. The following guide is relevant for Release 1805

Keywords

output, management, application log, sales, billing, invoice, partner, parameter , KBA , SD-BF-OC , Output Determination , Problem

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions