Symptom
JDM Migration Failure: Error getRoleIdsRuleIdsMap for baseUserId [null].
Environment
SuccessFactor Job Profile
Reproducing the Issue
Step 1: Go to Provisioning > Company Settings > Click " Migrate " in JDM v2.0/Skills Management
Step 2: Go to Monitor Jobs > JDM Old to New Sync
Result:
Status: Failed
Details: Error getRoleIdsRuleIdsMap for baseUserId [null].
Cause
Error getRoleIdsRuleIdsMap for baseUserId [null] is encountered when Job Profile Object Security Setting was already configured/enabled from the instance prior to migration.
Resolution
In order to resolve the issue, Job Profile Object Security needs to be disabled.
Step 1: Go to Admin Center > Configure Object Definition > Object Definition > Job Profile > Make Correction
Step 2: Under Security Section
Secured: No
Permission Category: No Selection
Step 3: Save Job Profile Object
Step 4: Go to Provisioning > Company Settings > Click " Migrate " in JDM v2.0/Skills Management
Step 5: Go to Monitor Jobs > JDM Old to New Sync
At this point, JDM Migration should be successful. However if the migration still fails with a different issue, kindly create a new case for further investigation.
Note: Once the job got successful, Job Profile Object Security should be enabled back.
Keywords
JDM Migration, getRoleIdsRuleIdsMap, JDM Old to New Sync , KBA , LOD-SF-TIH-JPB , Job Profile Builder , Problem