Symptom
When accessing a talent pool, there is no candidate appearing
***Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental***
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Search for a candidate that you want to add to a talent pool.
- Click on 'Add' under talent pools, and add the talent pool name and the status of the talent pool that you would like the candidate added to.
- Navigate to Recruiting>Candidates>Talent pools, and click on the talent pool name that you added the candidate to.
- Notice how this candidate is not displayed in the talent pool.
Cause
Candidate Privacy Options are enabled, however the configurations relating to the country field have not been set up correctly.
Resolution
- Make sure that the user viewing the talent pool has a Country defined in the empolyee/user data file as per the below screenshot.
- Check the Country picklist to make sure the Country is defined as per ISO Country Standards.
Once the Country is configured correctly for the user, they should be now able to view talent pool members.
See Also
KBA: 2479642 - Candidate Search Error - Search Failed. Country is not configured or is not in the picklist
Keywords
Talent Pools; Candidate Privacy Options; Members not found , KBA , LOD-SF-RCM-CAN , General Candidate Issues (not Offers, not Profiles) , Problem