Symptom
Error message: CA-008: "User with ExternalId 'XYZ' does not exist" (where 'XYZ' represents the User ID) appears when you try to access E-Mail Integration work center.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Log into the system
- Go to E-Mail Integration work center
- Go to User Settings work center view
- You receive following error: "CA-008: User with ExternalId 'XYZ' does not exist"
Cause
Related provisioning is not done for this user.
Resolution
1. For an End User
The action needs to be done by a key user with according access (see section 2). In case the User Settings work center view is assigned to the affected end user, un-assign this view. The User Settings work center view should not be assigned to an end user. Then perform the provisioning for this user using the following steps.
- Login in to the system as key user
- Go to work center to E-Mail Integration -> Groupware Settings
- Navigate to Provisioning tab
- Search for the end user and click on the Provisioning button
In case such an key user is not available, create an SAP case with according information and provide the permission to perform the provisioning.
2. For a Key User
For a key user, the views 'Groupware Settings' under 'E-Mail Integration' as well as 'Business Users' in 'Administrator' work center should be assigned. Perform the provisioning for this user using the following steps.
- Login in to the system as key user
- Go to work center to E-Mail Integration -> Groupware Settings
- In case you still get an error, ask another key user to perform provisioning as described above
- In case no other key user is available, create an SAP case and provide the permission to perform the provisioning.
Keywords
E-mail Integration; User Settings; CA-008; , KBA , LOD-CRM-INT-OEM , Provisioning issues for OEM integration (eg iCRM) , How To