Symptom
While approving Rehire workflow request, below error pops up:
"The system tried to adapt the bookable period of time account <Time Account External Code> to booking start date DD/MM/YYYY and booking end date DD/MM/YYYY. This would leave at least one booking outside the new period, so the time account cannot be adjusted. Please remove the booking with booking type EMPLOYEE_TIME and booking date DD/MM/YYYY."
Environment
Successfactors - Employee Central Time Off
Reproducing the Issue
- Terminate an employee
- Rehire the employee
- Approve the rehire workflow and an error pops up as below:
"The system tried to adapt the bookable period of time account <Time Account External Code> to booking start date DD/MM/YYYY and booking end date DD/MM/YYYY. This would leave at least one booking outside the new period, so the time account cannot be adjusted. Please remove the booking with booking type EMPLOYEE_TIME and booking date DD/MM/YYYY."
Cause
This happens when the Time Account Type is based on Flexible Start Date. When the employee is rehired, the existing time account's validity(Valid from and Valid To dates) gets changed based on the flexible start date configuration (in time account type) and does not delimit the old time account. When the new time account's validity is changed and if any employee time exists before the time accounts new validity, the error is thrown.
To replicate the scenario:
- Configure a Time Account Type with Time Account type start date as 'Flexible Start Date'.
- Hire employee 1st july 2018(by assigning the time profile). Time account valid from 1st July 2018 to 30th June 2019.
- Apply a leave on 3rd July 2018.
- Terminate employee 6th July 2018
- Rehire employee 15th July 2018. On approving the rehire workflow the above mentioned error pops up because the existing(old) Time account's validity is being changed to 15th July 2018 to 14th July 2019 but the employee time is outside the new time account validity.
NOTE: In b1805, the issue can be reproduced by changing the time profile (via Data Change) to another time profile which still contains the same flexible account type.
Resolution
- Currently the old Time Accounts are not delimited and new time accounts created when the employee is rehired. Therefore the old time accounts needs to be closed using the Interim update rules (Please refer the handbook "Employee Central Time Management: Rules and Concepts" for more details on how to configure the interim update rules).
- From 1808, the engineering team has fixed this where the old time account gets closed and a new one gets created
I.e in the aboe scenario, the expected behavior will be:
- Existing account validity changed: 1st July 2018 to 14th July 2018
- Another account created for rehire: 15th July 2018 to 14th July 2019
Keywords
Time Off The system tried to adapt the bookable period of time account <Time Account External Code> to booking start date DD/MM/YYYY and booking end date DD/MM/YYYY. This would leave at least one booking outside the new period, so the time account cannot be adjusted. Please remove the booking with booking type EMPLOYEE_TIME and booking date DD/MM/YYYY. Rehire Flexible Start Date Time Account Validity , KBA , LOD-SF-EC-TIM , Time Off , Problem