Symptom
You try to change the currency in a released Service Order, but the currency field is greyed out.
Environment
SAP Business ByDesign
Reproducing the Issue
-
Open the Service Orders workcenter.
- Create a new Service Order ABC (ABC represents the Service Order ID).
- Enter the necessary information to Release the Service Order.
- Release the Service Order to Service Execution.
- Navigate to the Pricing and Invoicing tab.
- Select the Invoicing Subtab.
The Currency field is greyed out.
Cause
-
This is the expected system behaviour.
- Currently the currency is greyed out, once the Status of the Service Order is set to In Process and all line items are released to Service Execution.
- If you want to change the currency, you need to add a line item that is not yet released to Service Execution.
Resolution
-
Open the Service Order ABC.
- Navigate to the Service and Spare Parts tab.
- Click on Add Row and select any item.
- Navigate to the Pricing and Invoicing tab.
- Select the Invoicing Subtab.
- Change the currency.
- Navigate to the Service and Spare Parts tab.
- Remove the created Row.
- Save the Service Order.
The currency for the existing Line items in the Service Order changes.
Keywords
Serviceauftrag, Preis, Währung, Service Order, Price, Currency, Abrechnung, Invoicing , KBA , AP-SVO-SO , Service Order , How To
Product
SAP Business ByDesign 1805 ; SAP Business ByDesign 1808