Symptom
Inconsistency on sales order due to the error: Address inconsistent for party ABC. (ABC represents the ID of any party in a sales order, for example, Ship-To party)
Environment
SAP Business ByDesign
Reproducing the Issue
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Go to Customer Invoicing work center.
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Go to Invoice Requests view.
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Show Inconsistent Invoice Requests view, and you can see the Sales Order Invoice Request is Inconsistent status.
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Click Check button, system tells the error:Address inconsistent for party Ship-To ABC. However, there is no change made on the address in Ship-To party.
- Click Determine All button, the error is not removed.
Cause
The region of the Ship-To party is set to Obsolete in Business Congiguration after creating the order. Hence, the region is invalid which leads to the inconsistency on the document.
Resolution
There are 2 options to solve the issue.
Option 1: Update the region code to a valid value in the party account ABC and update the document by using Determine All function.
Option 2: Remove the Obsolete flag from the affected region.
- Go to Business Configuration work center.
- Go to Overview view.
- Search activity: Regions.
- Select the row and click Change Immediately.
- Scroll down and find country=XYZ. (XYZ represents the ID of a country)
- You can see the code DEF is marked as Obsolete. You may remove the Obsolete flag. (DEF represnets the ID of a region)
- Save the change.
Keywords
Regions; BC activity; address inconsistent; account address; Region Code , KBA , SRD-CRM-ACC , Account Management , Problem