Symptom
On clicking the value help of Registered Product within the Lead, it displays no record found.
Environment
SAP Hybris Cloud for Customer.
Reproducing the Issue
- Go to the Customers work center.
- Go to the Account view and open an account XYZ1 (where XYZ1 represents an account id) .
- Go to the Registered Products facet.
- You can see, there exist an active Registered Product Productxyz ( where Productxyz represent registered product name).
- Now go to the Leads facet.
- You can see there exist lead LMN (where LMN represent lead name,which is created from Lead facet of an account XYZ1) .
- Open Lead LMN and go to the Registered Products facet.
- Click on the Add button and select Entry Type as Registered Product from drop-down option.
- Now click on the value help of Serial Id field.
- It opens the Registered Product window with Filter by Customer .
Here it show no record found.
Cause
The Registered Product name Productxyz, which exist in Registered Product facet of account XYZ1 belongs to some other Account.Therefore within Lead, the value help of Registered Product which is bydefault customer based filter shows no records.
Resolution
If you remove the filter by customer within advance search, you should be able to see the active registered product Productxyz.
-
Open Lead LMN and go to the Registered Products facet.
- Click on the Add button and select Entry Type as Registered Product from drop-down option.
- Now click on the value help of Serial Id field.
- Now in the Registered Product window, click on Advance filter option.
- Remove the Customer Id XYZ1 value and now click on Go button.
You will now be able to see the records for registered product Productxyz.
Keywords
Registered Product Value help ,Serial Id , No record found , KBA , registered product facet , lead , LOD-CRM-LM , Lead Management , LOD-LE-IBA , Installed Base Data Management , Problem