SAP Knowledge Base Article - Public

2670735 - Token Invalid Message When Connecting With Twitter Channel

Symptom

You have followed all the necessary steps to integrate C4C with Twitter but when clicking on Connect with Channel button in C4C, you receive following error message on Twitter site: 'Whoa there! The request token for this page is invalid. It may have already been used, or expired because it is too old. Please go back to the site or application that sent you here and try again; it was probably just a mistake.'.

Environment

SAP Cloud For Customer/ Service

Reproducing the Issue

  1. Go to Administrator work centre.
  2. Go to Service and Social view.
  3. Go to Social Media Channels.
  4. Open Twitter channel ABC (ABC represents Twitter channel ID).
  5. Click button Connect with Channel.
  6. Go back to Twitter and see error message: 'Whoa there! The request token for this page is invalid. It may have already been used, or expired because it is too old. Please go back to the site or application that sent you here and try again; it was probably just a mistake.'.

Cause

You have ticked following box on Twitter Application Management site: Enable Callback Locking (it is recommended to enable callback locking to ensure that apps cannot overwrite the callback url).

Resolution

Uncheck the checkbox on Twitter side as you have maintained C4C Callback URL already.

Please notice that for Twitter (aka "X"), starting on October 2024 there will be new guidelines and configuration details. More information can be seen at SAP Help Portal, under the topic "X (Formerly Twitter) Integration Discontinued" and provided by the official X partners.

See Also

SAP Hybris Cloud for Customer Integration with Twitter blog: https://blogs.sap.com/2016/07/28/sap-hybris-cloud-for-customer-integration-with-twitter/

Keywords

Twitter, Channel, URL, API , KBA , LOD-CRM-SC-SM , Social Media , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions