Symptom
The following error message occurs when adding a product with item type DIGI to a Sales Order: 'Item XX: Products with item group Spare part - direct goods issue not supported (XX represents the line item number)'.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Sales Orders work center.
- Select the Sales Orders view.
- Click on New button and select Sales Order.
- Enter the Account ABC (where ABC represents the Account ID).
- Navigate to the Items tab.
- Add Product XYZ (XYZ represents the Product ID).
The following error message occurs:
Item XX: Products with item group Spare part - direct goods issue not supported
Cause
The item group DIGI - Spare part - direct goods issue is designed for the Spare Parts Handling scenario. When executing a service order, the service engineers can perform a direct goods issue by entering a logistic area for the spare parts used. This item group is only supported in the Service scenario (Service Orders) and not in the Sales scenario (Sales Order).
Resolution
This is the expected system behaviour.
If your requirement is to use the same product in both Sales and Service scenarios.
The only way you would be able to use the same Product in both the Sales and Service scenarios would be via different Distribution Chains for the Sales and Service scenarios in the Sales tab of the Product Master Data. When you open the product and navigate to the Sales tab you are able to add a Sales Organization and a Distribution Channel. In the Sales sub tab you can then maintain the item group. It is possible to maintain multiple Sales Organizations with different Distribution Channels and these can then have different item groups.
For example:
You add Sales Organization A with Distribution Channel Direct Sales and maintain for this the item group DIGI.
Then you add Sales Organization B with Distribution Channel Direct Sales and maintain for this the item group NORM.
In a Sales Order you would need to select a Sales Unit belonging to Sales Organization B. When you then add the product the item type NORM will be determined in the Sales Order.
In a Service Order you would need to select a Sales Unit belonging to Sales Organization A. When you then add the product the item type DIGI will be determined in the Service Order.
Alternatively you could also use the same Sales Organization but different distribution Channels for the Sales and Service scenarios.
Keywords
digi; spare part; direct goods issue; sales order; item type; item group; sales organization , KBA , AP-SLO-SO , Sales Order , How To