SAP Knowledge Base Article - Public

2671100 - Unable To Send PDF Attachments Using Workflow Rules For Leads

Symptom

You are unable to send PDF attachments using e-mails via Workflow Rules.The option 'PDF Attachment' and 'PDF Form Templates' is available in General Data facet but disappears once you enter Edit mode.

Environment

SAP Hybris Cloud For Customer.

Reproducing the Issue

  1. Go to Administrator work center.
  2. Go to Workflow Rules view.
  3. Click on New.
  4. Select Leads Business Object from the dropdown and enter the Description.
  5. Click on Next.
  6. Define the Conditions and click on Next.
  7. In Define Actions screen select the Rule Type as 'E-Mail' and fill the mandatory fields.
  8. Here you are unable to find options to add PDF attachments- 'PDF Attachment' checkbox and 'PDF Form Templates'.
  9. Go to Review screen and click on Finish.
  10. Click on Close.
  11. Now open the workflow you just created.
  12. In the General Data facet you are able to see options 'PDF Attachment' and 'PDF Form Templates' but once you enter edit mode you are unable to find these options.

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Cause

For Leads 'PDF Attachment' and 'PDF Form Templates' is not enabled hence once you enter edit mode these two options disappear from Define Actions section.

Resolution

This is expected system behaviour.

You can send your own custom template by following these steps:

  1.  Define workflow rule and select the checkbox "Add Attachment", in "Define Action section" step.
  2.  Custom logic to attach any template, must be created by the user.

 

Keywords

pdf,Add Attachment,workflow,email , KBA , pdf form templates , pdf attachment , lead , e-mail , LOD-CRM-WKF , Workflow , LOD-CRM-LM , Lead Management , Problem

Product

SAP Cloud for Customer add-ins 1805 ; SAP Cloud for Customer add-ins 1808 ; SAP Cloud for Customer add-ins 1811

Attachments

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