Symptom
You are unable to send PDF attachments using e-mails via Workflow Rules. The option 'PDF Attachment' and 'PDF Form Templates' is available in General Data facet but disappears once you enter Edit mode.
Environment
SAP Cloud For Customer.
Reproducing the Issue
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Go to Administrator work center.
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Go to Workflow Rules view.
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Click on New.
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Select Leads Business Object from the dropdown menu.
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Click on Next.
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Define the Conditions and click on Next.
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In Define Actions screen, select the Rule Type as 'E-Mail' and fill the mandatory fields.
- Select "Yes" for Add Attachment
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Here you are unable to find options to add PDF attachments- 'PDF Attachment' checkbox and 'PDF Form Templates'.
Cause
For Leads 'PDF Attachment' and 'PDF Form Templates' is not enabled hence once you enter edit mode these two options disappear from Define Actions section.
Resolution
This is expected system behaviour.
You can send your own custom template by following these steps:
- Define workflow rule and select the checkbox "Add Attachment", in "Define Action section" step.
- Custom logic to attach any template, must be created by the user.
Keywords
pdf, Add Attachment, workflow, rules, rule, e-mail, Leads, Business Object, , KBA , pdf form templates , pdf attachment , lead , e-mail , LOD-CRM-WKF , Workflow , LOD-CRM-LM , Lead Management , Problem
Product
Attachments
wf1.png |
wf2.png |