Symptom
Your requirement is to maintain the number ranges for Accounts, Suppliers, Contacts, Business Partners. But, in Business Configuration work center, you are unable to find the fine-tuning activity to maintain number ranges with respect to each of these objects.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Business Configuration work center.
- Access the Overview work center view.
- Search for the fine-tuning activity to maintain the number ranges with respect to each of these objects Accounts, Suppliers, Contacts, Business Partners.
- Unable to find the same.
Cause
To maintain the number ranges, there is no separate fine-tuning activity with respect to each of the objects like Accounts, Suppliers, Contacts, Business Partners.
Resolution
All types of Business Partners like Accounts, Suppliers, Contacts share the same number ranges.
You can maintain the number ranges for Accounts, Suppliers, Contacts and Business Partners in a single activity.
- Go to Business Configuration work center
- Select Implementation Projects view or Overview
- Search and Open the activity General Business Partners
- Select Define Number Ranges for Business Partners
- Maintain the number ranges as required
Note:
- It is not possible to create different number range specific for Accounts, Suppliers, Contacts, Business Partners.
- When you create a Business Partner, you may use Internal number ranges if you want the system to automatically assign a number.
- When you create a Business Partner, you may use External number ranges if you want to enter the number manually.
- Create number ranges with sufficient intervals to avoid future complications.
- Ensure that the intervals of internal and external number ranges do not overlap.
- Ensure that the ID length specified is not shorter than the length of any IDs that are currently in use in the system.
- Changing previously assigned number ranges can lead to problems in the system.
- If a Business Partner is already available in system, you would not be able to change the number range interval as there is a Veto check in the backend that identifies that there is already a Business Partner in the system. So, the attempt is to change the interval to new values, where there is at least one number already used from this interval for an already existing Business Partner is not allowed because it would lead to collisions of numbers.
- You may extend the End Number in the interval to a higher range. When you adapt the interval boundaries, ensure that they do not overlap with existing Business Partners and of course not with each other. This might require some tries because we would not be able to predict which IDs are already in use.
- It is not possible to change or swap the number range between Manual and Automatic once the Business Partners are already uploaded.
- It is not possible to delete the Master Data (Accounts, Suppliers, Contacts, Business Partners etc.) once they are created in the system.
- The Internal number ranges are used automatically by the solution during productive use, for example, if you create the data manually using the regular work center UI.
- We recommend that you use the predefined number ranges.
- Change the predefined number ranges only if necessary and mind the consequences.
- In the Migration Tool, for some objects, you choose whether you want to keep the IDs from the legacy system or whether you want to assign new IDs automatically. If you keep the IDs from the legacy system, make sure the number range defined in Fine-Tuning satisfies the requirements of the IDs. If assigning new IDs automatically, the total number of records must not exceed the number range defined in Fine-Tuning activity.
- The External number Range from “A” to “ZZZZZZZZZZ” is not open for edit and cannot be changed. The allowed characters are: ABCDEFGHIJKLMNOPQRSTUVWXYZ0123456789_-/:\. This interval allows to maintain alphanumerical IDs for Business Partners, but it must start with a letter. For example: “.A123” is not allowed but "A.123" is allowed.
Account IDs and Contact IDs
While migrating Accounts using the Migration of Customers, in the Convert Values step of the migration tool, you can decide if you want to keep the IDs from your legacy system as Account ID or if the system should automatically assign new Account IDs for all migrated records. The new numbers will be taken from the numeric internal number range.
For the Contact ID, the system automatically assigns new IDs for all migrated contacts. New Contact IDs will be generated based on the number range settings you defined using the General Business Partners activity in the Fine-Tune phase of the activity list. The new numbers will be taken from the numeric Internal number range.
Supplier IDs
While migrating Suppliers using the Migration of Suppliers, in the Convert Values step of the migration tool, you can decide if you want to keep the Supplier IDs from your legacy system or if the system should automatically assign new Supplier IDs for all migrated records. The new numbers will be taken from the numeric Internal number range.
Account IDs, Contact IDs and Supplier IDs
When you create using the webservices where you manually specify the IDs in the Request payload, the numbers will be taken from the External number range. When you create using the webservices where you do not specify the IDs in the Request payload, the numbers will be automatically taken from the Internal number range.
Keywords
Number Range, Account, Contact, Supplier, Business Partner, Internal, External , KBA , business partners , number ranges for business partners , number ranges for accounts , number ranges for suppliers , number ranges for contacts , SRD-MD-BP , Business Partner , How To