2673269- The New Visit is Not Visible in The Visit Details Tab
Symptom
You have created a Visit from the Visit Details tab in the Account TI, but it is not visible in the Visits Pane.
Environment
SAP Cloud for Customer
Reproducing the Issue
Go to the Customers work center.
Go to the Accounts view.
Open the Account ABC (ABC represents the Account ID).
Go to the Visit Details tab.
In the Visit Details pane, select the Add button.
Select the Visit Type DEF (DEF represents the Visit Type ID).
Leave the Sales Organization,
Select the Add button and then Save.
In the Visits pane, select the New button.
The Visit Type DEF is defaulted from the Visit Details.
Maintain a value in the Sales Organization, Distribution Channel and Division fields if the system does not already automatically determine them (depending on the configuration maintained in Business Configuration).
Select the Save button.
The Visit is not visible in the Visits pane but it is in the Visits tab.
Cause
This is the expected system behaviour. Only the Visit Type has been maintained in the Visit Details and not the Sales Organization, Distribution Channel and Division. Because of this, if a new Visit is created, mostly likely the newly created Visit gets some auto assignment of Sales Org, Distribution Channel and Division trio (based on the way business user is configured) and this new Visit will not appear in this Visit Details tab.
Resolution
In general if any of the Sales Org, Distribution Channel or Division is maintained in the Visit Details, then the Visit will be visible in the Visits pane.