SAP Knowledge Base Article - Public

2673434 - After Clicking the Edit Button E-mail Screen Does not Lead to Edit Mode

Symptom

You click the edit button in the Activities E-mails, but do not see any change in the user interface.

The Screen seems to remain in display mode.

Environment

SAP HYBRIS CLOUD OR CUSTOMER

Reproducing the Issue

  1. Go to the Activities workcenter.
  2. Go to the E-mails view.
  3. Open any E-mail.
  4. Click Edit.

Result: The screen does not show any change from display mode to edit mode. No field editable.

Cause


The purpose of the Edit button for E-mails under Activities is to modify the Sales Territory field, which is allowed to be changed when the e-mail reaches the status Completed.

This field is not displayed by default - it requires to be enabled via personalization/adaptation.

Unlike adding follow-up items where the edit and the save are implicitly called, for header level fields, Edit has to be explicitly called to change those fields.

Resolution

This is the expected system behaviour.

Keywords

Edit Mode, Edit button, E-mail, Activities , KBA , LOD-CRM-ACT , Activities , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions