Symptom
The exception aggregation field is cleared when a shared dimension is updated in SAP Analytics Cloud (SAC).
Environment
- SAP Analytics Cloud 2018.12
Reproducing the Issue
Reproduction steps:
- Open a Planning enabled model that uses a public account dimension and modify a member in the account dimension (ex: by changing the decimals property value from 2 to 0)
- Now open another model that uses the same public account dimension and notice the Exception Aggregation is empty (It was previosuly SUM)
- Notice that the exception aggregation dimensions are still set even though the Exception Aggregation is empty
- If you try to modify a formula, the error "Exception Aggregation Type cannot be empty if an Exception Aggregation Dimension is selected"
Cause
- This issue was due to the fact that the exception aggregation dimensions were not the same in both models.
- A public account dimension needs to have the same Exception Aggregation Type and exception aggregation dimensions across all models.
- Behaviour of a Global (public) Account Dimension:
- The concept of a global account dimension is to ensure that the common accounts (base, calculated) behave the same across all the Models in which the account dimension is shared.
- It does not make sense to have different exception aggregation types for the same account in different models.
- Any change done to the system defined settings like "ID, Description, Account Type, Hierarchy, Unit & Currencies, Aggregation Type, Exception Aggregation Type, Scale, Decimal Places, Calculate On, Hide" will have impact across all the models. The same is applicable for User defined settings or columns) as well.
- The only difference to this rule above is "Formulas" based on dimensions. You can define different formulas for the same account but be aware that you cannot choose to have different exception aggregation type for the same. Such configurations are not recommended.
- If you want to have different settings for different account members then it's always advisable to use a local account dimension (or create a new global dimension specific only to that one model).
Resolution
This behaviour is as designed and there is no plan at the moment to enhance the current behaviour.
See Also
- How to find User Assistance for SAP Analytics Cloud?
- Ask a question on the SAP Community!
- 2487011 - What information do I need to provide when opening incidents with SAP Analytics Cloud (Hint: Use component LOD-ANA*)
Your feedback is important to help us improve our knowledge base.
Please rate how useful you found this article by using the star rating feature at the beginning of this article.
Thank you.
Keywords
SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, EPM-ODS, Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics , KBA , LOD-ANA , SAP Analytics Cloud (SAC) , LOD-ANA-BI , Business Intelligence Functionality, Analytic Models , LOD-ANA-PL , Planning , LOD-ANA-BR , SAC Boardroom , LOD-ANA-PR , SAC Predictive , Problem