Symptom
Warranty Start Date and End Date Not Getting Calculated for Existing Registered Product
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
-
Go to Products Work Center
- Then to Registered Product View
- Open any Registered Product XYZ, where, XYZ is any Registered Product ID
- Navigate to Overview Facet
- Under Warranty Section, enter Local Warranty (provided valid Start date, End date, Duration is present) maintained in the system
It is seen that the Warranty Sart Date and Warranty End Date fields are not defaulted
Cause
Warranty Sart Date and Warranty End Date are calculated from Registered Product Reference Date
Resolution
- Go to Products Work Center
- Then to Registered Product View
- Open any Registered Product XYZ, where, XYZ is any Registered Product ID
- Now in the Header Section, kindly maintain the value for Reference Date field
- And now on entering the Local Warranty, the Warranty Sart Date and Warranty End Date gets populated
Keywords
Warranty End Date,Warranty Start Date,Registered Product,Local Warranty,Warranty , KBA , registered product , local warranty , warranty , warranty end date , warranty start date , LOD-LE-PRD , Product + Product Category , Problem
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions