SAP Knowledge Base Article - Public

2673957 - Onboarding Activity Re-Assigned to a Random Assignee/User - Onboarding 1.0

Symptom

  • The Onboarding activity is re-assigned to a random assignee/user automatically after completing New Employee Step (NES).
  • The Orientation Step is assigned to a random user.  

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

 

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. The Candidate Completes the New Employee Step and Activity is moved to Orientation Step.
  2. Orientation Step is assigned to a different user as expected.

Cause

Due to the assign option in the process Onboarding activity is automatically re-assigned to a random assignee/user. See below for more details.

The OS_AssigneeUserId is added as the assign option key to receive the activity and Orientation Manager is not enabled in Onboarding Back-End. Hence, it will follow the second assign option which is auto.

OS_AssigneeUserId.png 

Orientation Manager.png

NOTE:

  • The panel SAP_Standard_OrientationManagerSetup will not be available if Orientation Manager is not enabled and the key OS_AssigneeUserId will not be generated.
  • Assignee Options are different to every customer.

Resolution

There are different ways to rectify this incorrect configuration and below is the solution:

 

  1. Enable Orientation Manager in Onboarding Back-End. After enabling the feature, the panel SAP_Standard_OrientationManagerSetup will show in Post-Hire Verification Step (PHV) and Assignee in PHV will be able to add the Orientation Step (OS) Assignee.
  2. Remove the OS_AssigneeUserId in Assign Option in the Orientation Step of the Process and replace it with a role or specific person to receive the activity as Assignee

 

NOTE:

  • Since this is a configuration, this type of changes might alter your business requirements set by your implementation partner. 
  • Only SAP Professional Services, Implementation Partners, and SAP Cloud Product Support can have access to SAP SuccessFactors Onboarding Back-End (Super Admin).

 

FOR CUSTOMER:

Submit a ticket to SAP SuccessFactors Cloud Support via SAP for Me to verify the settings in Onboarding Back-End.

If Product Support verified that issue is same with the cause in this KBA, we highly advice and suggest you reach-out to the person/team who configured this and rectify the configuration.

FOR IMPLEMENTATION PARTNERS:

All the needed information and resources regarding on how to properly setup Onboarding is located at KBA 2116056 - Partner Support - Resources & Tools.

See Also

2673962 - Information - What is the use of key OS_AssigneeUserId - Onboarding [Panels]

2149831 - To contact Professional Services, Partner and Account Management Team

2116056 - Partner Support - Resources & Tools

Keywords

On Boarding, OBD, Onboarding 1.0, SuccessFactors , KBA , LOD-SF-OBD-PAN , Panels, Panel Designer , Problem

Product

SAP SuccessFactors Onboarding all versions