SAP Knowledge Base Article - Public

2674762 - DRTM Purge errors related to user's Country

Symptom

  • DRTM Master Data Purge or DRTM Learning Data Purge throw one of the following errors:
    • There is no country specified for this user or user's country is not DRM enabled error.
    • Country code doesn't exist or this country doesn't enable DRM. Please check picklist country or MDF country configuration for identity.
    • There is no retention time defined for this country.

Environment

  • SAP SuccessFactors HCM 
  • SAP SuccessFactors Learning

Cause

  • "DRTM Master Data" upgrade was not performed in your instance using "Upgrade Center".
  • The to be purged user is not an Employee account type.
  • No country, start date or exit date was maintained for the user to be purged.
  • The user’s country does not have "Data Retention Enabled" set as “Yes” or the time retention is not configured for it.
  • User’s country field is not the same as the one in the picklist mapped for it, hence the mapping cannot be done between UDF and Manage Data.

Resolution

To resolve DRTM Purge errors related to a user's country, please follow the step-by-step instructions available in the dedicated Guided Answers for a thorough troubleshooting process:

Troubleshooting DRTM Master Data Purge error: There is no country specified for this user or user's country is not DRM enabled

See Also

Keywords

DRTM, country, code, failed, straight, picklist, data, retention, management, learning, purge, master , KBA , LOD-SF-PLT-DRM , Data Retention Management , LOD-SF-LMS , Learning Management System , LOD-SF-PLT , Platform Foundational Capabilities , LOD-SF-LMS-UDR , User Data Purge , LOD-SF-EC-DRM , Data Retention Management - (DRM & DRTM) EC Data Only , Problem

Product

SAP SuccessFactors HCM Suite all versions ; SAP SuccessFactors Learning all versions