SAP Knowledge Base Article - Public

2674762 - DRTM Purge errors related to user's Country

Symptom

  • DRTM Master Data Purge or DRTM Learning Data Purge throw one of the following errors:
    • There is no country specified for this user or user's country is not DRM enabled error.
    • Country code doesn't exist or this country doesn't enable DRM. Please check picklist country or MDF country configuration for identity.
    • There is no retention time defined for this country.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

  • SAP SuccessFactors HCM 
  • SAP SuccessFactors Learning

Cause

  1. "DRTM Master Data" upgrade was not performed in your instance using "Upgrade Center".
  2. The to be purged user is not an EMPLOYEE account type.
  3. No country, start date or exit date was maintained for the user to be purged.
  4. The user’s country does not have "Data Retention Enabled" set as “Yes” or the time retention is not configured for it.
  5. User’s country field is not the same as the one in the picklist mapped for it, hence the mapping cannot be done between UDF and Manage Data.

Resolution

With 1H 2024 Production Release, the option "Ignore data retention time configuration for this purge request" for DRTM Master Data purge requests enables you to purge data immediately with fewer restrictions. With the option selected, the DRTM Master Data Purge can skip the validation of the users' country/region record and termination date record. More information about this enhancement can be found in Enhancement to DRTM Master Data Purge | SAP Help Portal

To use DRTM Master Data Purge to purge users based on configurable data retention times, please confirm the configurations are correctly setup by following the troubleshooting steps below.

  1. Check if the required "DRTM Master Data" purge object was added to your instance, using the Upgrade Center:
    1. Go to Upgrade Center >
    2. Under Optional Upgrades, search for DRTM Master Data.

Alternatively, you can check under "View Recently Completed Upgrades". 

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  1. Check in Data Inspector if the user is EMPLOYEE or ONBOARDEE account type
    1. Go to Data Inspector
    2. Select Table_USER_ACCOUNT
    3. "Add Criteria"
    4. Choose "Username" > Equals > Populate with username > Show Data
    5. Check what is the Account Type for the record you are trying to purge:
      If it's ONBOARDEE, please follow the KBA 3052056 - How to delete or permanent purge an inactive onboardee user - Onboarding - SAP for Me
      If it's EMPLOYEE, please go ahead with the next steps to perform the checks and resolve the country related issue.
  1. Check in the Employee Export file if the fields “Country”, “Start Date” and “Exit Date” are configured and populated for the user in question. 
  • If the Exit Date is not configured, please follow the steps in document Adding the CompanyExitDate Field to the User Record | SAP Help Portal to add and populate.
  • Review the user start date as it's only possible to purge users considering data retention times on/after the Start Date.
  • Also review the Country and Exit Dates field and make sure they're populated for the user.

Note:

For EC Users, the user country information derives from the Job Info records and User Exit date from Employment Info. For non EC Users, the user country information derives from users_Info and User Exit date derives from users_sysInfo.

  1. Check if the time retention is set for the user country. Those steps are fulfilled when you implement the DRTM Master Data feature, as per KBA 2615360 - Data Protection and Privacy - Data Retention Time Management (DRTM) - Master Data Purge for Inactive Users (sap.corp)
  • To check if Data Retention is set as “Yes”:

    1. Go to Manage Data >
    2. From the menu, select "Country/Region" option >
    3. From the other box, select the country and check if the Data Retention field is set as “Yes”. If not, please correct it.

contry.PNG 

  • To check if the time retention is set for the country:
    1. Go to Manage Data >
    2. From the menu, choose DRTM Master Data >
    3. Select "USER(USER)" and check if the country is listed and if the information is populated. You can choose between years/months and the number you set is the number of years or months the retention will be required for that user.

Note: This configuration will not purge the users automatically, it will only set a restriction to run the DRTM Master Data purge job for them. Also, if you cannot find the USER(USER), please make sure the step 1 from this KBA's resolution was followed.

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  1. Ensure the Country Field is matching MDF Country Entity and/or in the picklist mapping:
  • First, if the translation field is correctly populated:
    1. Go to Manage Data >
    2. From the menu, select Country/Region option >
    3. From the other box, select the country and click on "Country Translation" (icon next to country name) and place the same value that is in country field. For example, if in country field is place United States in the "Country Translation" you must place United State as well.
  • Second, check if the standard element "Country" in your company is mapped to any picklist ID:

    1. Go to Manage Business configuration >
    2. Employee Profile >
    3. Standard >
    4. Country >
    5. Check the picklist field if it is mapped.

If not, make sure the user's country field in UDF matches the country’s default value field in Manage Data. 
If yes, perform the steps below:

    1. Go to Admin Center >
    2. Picklist Center >
    3. Search for the Picklist ID you see in the previous step >
    4. In the Picklist ID, search by the user country and ensure that the external code field matches the one configured for the country in Manage Data. 

Note:

  • If Learning Module is enabled in your instance ensure that the following permissions are granted, refer to the KBA 2179378.
  • Job information should exist in employee profile for the user being purged.

See Also

Keywords

DRTM, country, code, failed, straight, picklist, data, retention, management, learning, purge, master , KBA , LOD-SF-PLT-DRM , Data Retention Management , LOD-SF-LMS , Learning Management System , LOD-SF-PLT , Platform Foundational Capabilities , LOD-SF-LMS-UDR , User Data Purge , Problem

Product

SAP SuccessFactors HCM Suite all versions ; SAP SuccessFactors Learning all versions