Symptom
Once the Opportunity's Probability is changed manually, the system does not update it when the Sales Phase gets changed.
Environment
SAP Cloud For Customer
Reproducing the Issue
- Go to the Sales work center.
- Go to the Opportunities view.
- Open the Opportunity 123(where 123 is Opportunity ID).
- Enter edit mode and change the Sales Phase.
- The opportunity's Probability does not get updated.
Cause
There are two possibilities in this scenario:
- You have changed the Probability manually or
- The Probability maintained in the Opportunity does not match the values maintained in Business Configuration Fine-Tuning.
Resolution
For the first scenario, this is the expected behavior. If the automatic Probability is changed manually, it means that the Opportunity does not follow the default rules anymore, hence no updates are done by the system anymore.
For the second scenario, if the phase is changed, the probability is adjusted to the values maintained in BC only if the current probability matches the probability maintained for the current phase. If there is a mismatch, the system detects is as not fitting and the probability is not adjusted.
In order to solve this, you can change the Probability manually to a value which fits the ones maintained in Business Configuration and then save it. Then, once you change the Sales Phase again, the Probability will change automatically, according to the configuration maintained in your system.
See Also
Keywords
Opportunity , Sales Phase , Sales Cycle, opportunity Probability field , KBA , probability , sales , opportunity , sales cycle , sales phase , LOD-CRM-OPP , Opportunity Management , Problem