SAP Knowledge Base Article - Public

2677035 - Route Visits Automatic Rescheduling Does not Take Place After Changing the Start Time

Symptom

After modifying the Start Time you initially maintained in a Route, the different proposed Visits you created can be saved successfully although they conflict with the new Route Start Time.

Environment

SAP CLOUD FOR CUSTOMER

Reproducing the Issue

  1. Go to the Visits workcenter.
  2. Go to the Routes view.
  3. Open ABC (ABC represents a Route whose Start Time and was previously set, along with Proposed Visits).
  4. Change the Start Time of The Route.

Result: The existing Visit time slots are not shifted to align with the new Start Time, yet saving the Plan is possible.

Cause

The Start Time in Visit Routes is designed to work in such way that for each new day of Visits created, the system will take into account the Start Time maintained in the object, going forward.

It is considered out of the business logic to start the Visit plan with a Start Time, and, having already setup visit times for an entire day from that date and time on, readjusting the Start Time.

This could cause inconsistencies within the planned day, as well as in previously planned days, where the times of each visit may now fall to time slots that are now not available for visiting.

Resolution

This is the expected system behavior.

Keywords

Route Visits, Routes, Start Time. , KBA , LOD-CRM-PM , C4C Product Management , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions