SAP Knowledge Base Article - Public

2677120 - Party Role Phone Call Participants Does Not Provide Access Rights for Phone Call Activity

Symptom

Party role Phone Call Participants does not provide access rights for Phone Call activity.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Set Access Rights for Phone Calls Activity as Restricted for the user ABC (in which ABC defines the user ID).
  2. Maintain the Rule based on Employee for the user ABC.
  3. Create a Phone Call activity 123 (123 defines the Phone Call ID)
  4. Defined the user ABC as a Phone Call Participant.
  5. Log in with the user ABC.
  6. Go to Activities work center.
  7. Go to Phone Calls work view.
  8. Select the query "My Phone Calls"
  9. The user ABC is not allowed to see the Phone Call 123 on the Phone Call list.

Cause

As per the current system behavior, the Phone Call Participant should be allowed to access the Phone Call in case the user is an owner or is an employee. Otherwise, by default system behavior, the user should not be able to access the Phone Calls maintained on the system.

Resolution

This is the current system behavior. In case you need to provide access rights for Phone Call Participants you may already utilize PDI to add participants to the Phone Call access control list through PDI named CustomAccessControlListWrite in SAP Cloud Applications Studio.

Besides, you may contact your implementation manager to help with such request or approach directly the SAP Cloud Service Center.

You can find more details about the services offered by Cloud Service Center on https://www.sap.com/services/application-development.html . You can contact Cloud Service Center as follows:

  1. If you are a partner: please use cloudsolutionpartner@sap.com or the Partnerfinder
  2. If you are a customer: please use the little blue box “Contact Us” shown on the very right hand side of https://www.sap.com/services/application-development.html, choose “Contact Us”, choose “Services”, choose “SAP Custom Development” and complete the page


Note: The services of the SAP Cloud Service Center will be charged as packaged services based on fixed prices.

An alternative option may be to check the SAP Hybris Cloud for Customer Ideas Forum to submit an idea: https://influence.sap.com/SAPCloudforCustomer

See Also

SAP Blog - Access Control Management: Basics of access control and business roles

SAP Admin Guide - Setting Up User Access Rights and Restrictions

Keywords

Phone Call, Access Rights, Phone Call Participants. , KBA , LOD-CRM-ACT , Activities , How To

Product

SAP Cloud for Customer add-ins 1808 ; SAP Cloud for Customer add-ins 1811