SAP Knowledge Base Article - Public

2677451 - Non-Billable Flag is not editable in the Service Order which is created from Customer Contract

Symptom

You are not able to edit the Non Billable Flag in the Service Order which is created as a Follow Up of a Customer Contract.

Environment

SAP Business Bydesign

Reproducing the Issue

  1. Go to Service Orders work center.
  2. Navigate to the View Service Order Processing.
  3. Search for your service order XYZ, select it and choose the Edit button(XYZ is the id of the Service Order).
  4. In the service order screen choose the View All button , navigate to the tab Services and Spare Parts and select the button Add Row.
  5. Select a line item and under General Section, the field Non-Billable is not editable.

Cause

The Service Order is created as a follow up of a Customer Contract. Curently it is not possible to edit the Non-Billable flag in the Service Order which is created as Follow-Up of Customer Contract because when you have Contract->Service Order->Service Confirmation in system then the accounting document is Contract.


Note: This is applicable only for the line items which has Contract as reference, you can edit Non-Billable Flag for any new Item which you add to the Service Order.

Resolution

This functionality is currently not available.

Keywords

Non-Billable Flag; Cannot edit non billable flag in service order; edit non billable flag; , KBA , AP-SVO , Service Order Processing , Problem

Product

SAP Business ByDesign 1808