SAP Knowledge Base Article - Public

2677828 - E-Mail Address Maintained for Dunning Letters Not Picked Correctly

Symptom

In the Communication - Addresses tab of a Customer's master data you maintain two addresses:
- The main address with e-mail address exampleABC@example.com.
- a second address maintained as Bill-to and Dun-to with e-mail address exampleDEF@example.com

As a result, an invoice to the customer is correctly output to the Bill-to-e-mail address.
But the Dunning letter, generated through an automatic dunning run is addressed to the e-mail address of the main address, exampleABC@example.com.

Environment

SAP Business ByDesign

Reproducing the Issue

To check the Customer's addresses:

  1. In the Account Management work center go to the Accounts view.
  2. Find Customer XYZ and press Edit - Addresses to open the Communication- Addresses tab of the Customer's master data.
  3. Two addresses appear:
    The first address is marked as Main Address as well as Ship-To.
    - In the Communication section, in the E-Mail field you find exampleABC@example.com.
    The second address is not marked as Main, but as Bill-To and Dun-To.
    - In the Communication section, in the E-Mail field you find exampleDEF@example.com.

You expect that all invoice and Dunning Letters are sent to the second address, exampleDEF@example.com.
Instead, invoices are correctly output to the second e-mail. But Dunning letters, aromatically generated by the Dunning run are sent to the address defined for the Main address:

  1. In the Receivables work center go to the Dunnings tab.
  2. Select Dunning XXX (XXX represents the dunning ID) for customer XYZ.
  3. Press Preview and select Send Options.
  4. In the pop-up window, under Output Details check the E-Mail Settings.
  5. Here, under To the e-mail address of the Customer's Main address appears, exampleABC@example.com.

Cause

In the current SAP Business ByDesign Release the communication details for Dunning letters are derived from the address defined as Main address.

Resolution

This is current, expected system behavior.
There is, however, a workaround: If you maintain the e-mail address for dunning letters i the Communication- Collaboration sub-tab then this e-mail is prioritized for the Dunning Letter output:

  1. In the Account Management work center go to the Accounts view.
  2. Find Customer XYZ and press Edit - Addresses to open the Communication- Addresses tab of the Customer's master data.
  3. From here go to the Collaboration sub-tab.
  4. Under Business Document Setting find Business Document Dunning Outbound.
  5. In the Output channel column select E-Mail.
  6. In the E-Mail column enter the e-mail address specified for Dunning letters, exampleDEF@example.com.

After this check the Send Options of the dunning letter again, provided it has not been sent in the meantime.
This time the correct e-mail address is fetched.

Keywords

Dunning letter wrong e-mail address, Dun-To, Dunning letter Send Options , KBA , mahnung e-mail adresse , dunning letter wrong e-mail address , dun-to e-mail address , AP-DUE , Due Item Processing , Problem

Product

SAP Business ByDesign all versions